Commit a105d636 authored by Benjamin's avatar Benjamin
Browse files

update requirements.txt and setup.py

parent b8840937
from setuptools import setup from setuptools import setup, find_packages
setup( setup(
name="animalai", name="animalai",
version="2.0.0b0", version="2.0.0b0",
description="Animal AI competition interface", description="Animal AI envronment Python API",
url="https://github.com/beyretb/AnimalAI-Olympics", url="https://github.com/beyretb/AnimalAI-Olympics",
author="Benjamin Beyret", author="Benjamin Beyret",
author_email="bb1010@ic.ac.uk", author_email="beyretb@gmail.com",
classifiers=[ classifiers=[
"Intended Audience :: Developers", "Intended Audience :: Developers",
"Topic :: Scientific/Engineering :: Artificial Intelligence", "Topic :: Scientific/Engineering :: Artificial Intelligence",
"License :: OSI Approved :: Apache Software License", "License :: OSI Approved :: Apache Software License",
"Programming Language :: Python :: 3.6", "Programming Language :: Python :: 3.6",
"Programming Language :: Python :: 3.7",
], ],
packages=[ packages=find_packages(exclude=["*.tests", "*.tests.*", "tests.*", "tests"]),
"animalai.envs",
"animalai.envs.gym",
"animalai.communicator_objects",
], # Required
zip_safe=False, zip_safe=False,
install_requires=["mlagents-envs==0.15.0", "jsonpickle", "pyyaml"], install_requires=["mlagents-envs==0.15.0", "jsonpickle", "pyyaml"],
python_requires=">=3.5", python_requires=">=3.5",
......
from setuptools import setup from setuptools import setup, find_packages
setup( setup(
name="animalai_train", name="animalai_train",
version="2.0.0b0", version="2.0.0b0",
description="Animal AI competition training library", description="Animal AI training library",
url="https://github.com/beyretb/AnimalAI-Olympics", url="https://github.com/beyretb/AnimalAI-Olympics",
author="Benjamin Beyret", author="Benjamin Beyret",
author_email="bb1010@ic.ac.uk", author_email="beyretb@gmail.com",
classifiers=[ classifiers=[
"Intended Audience :: Developers", "Intended Audience :: Developers",
"Topic :: Scientific/Engineering :: Artificial Intelligence", "Topic :: Scientific/Engineering :: Artificial Intelligence",
"License :: OSI Approved :: Apache Software License", "License :: OSI Approved :: Apache Software License",
"Programming Language :: Python :: 3.6", "Programming Language :: Python :: 3.6",
"Programming Language :: Python :: 3.7",
], ],
packages=["animalai_train"], # Required packages=find_packages(exclude=["*.tests", "*.tests.*", "tests.*", "tests"]),
zip_safe=False, zip_safe=False,
install_requires=["animalai==2.0.0b0", "mlagents==0.15.0"], install_requires=["animalai==2.0.0b0", "mlagents==0.15.0"],
python_requires=">=3.6.1", python_requires=">=3.6.1",
......
tensorflow>=1.7,<2.0 # if you wish to run examples using tf>=2.0 change the baselines requirement accordingly
animalai==2.0.0b0
animalai_train==2.0.0b0
baselines # replace with git+https://github.com/openai/baselines.git@tf2 to use tf2
jupyter
matplotlib
\ No newline at end of file
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment